Mod «Ultimate Tech Tree : New Horizon» for Hearts of Iron 4 (v1.11.4)

Date
13.01.22
Views
1769
Version
12.01.22

With over 1300 new icons this mod aims to extend the timeline to the 90s while introducing realistic looking unit icons and tech development.

COMPLETED NATIONS: USA, SOV, ENG, FRA, GER,♥♥♥ NAVAL TREE

Why are we reworking the mod ?
The mod named "Ultimate Tech Tree : Reforged Edition" created by Tolis is deprecated as with the new dlc "No Step Back" we can no longer play with it. So we took the initiative by reworking the mod by adding what was missing, adding new stuffs etc ...

What's in this newer version ?
Many expected an update from the original creator but Tolis is a bit busy so Ratapan and I are working on the newest version. We managed to add trains and doctrines back ! We also reworked the tech placement. I'd like to thanks Leoxyll which is the art designer for the futur content we'll add .

What's our plan ?
Fixing the mod so we can use it with the No Step Back DLC, adding trains from 1936 to 1990, introducing tank designer from 1936 to 1990 as of now.

Mod checked on game version: 1.11.4

  • FPS/lag issue experienced by many player has been fixed

Version 01.01.22 for Hearts of Iron 4 (v1.11.4)

  • Helicopter where consuming too much fuel
  • Helicopter range issue
  • Tank engine of 1934 allowed 18 level of engine upgrade
  • Tanks name
  • USA tanks icon having an issue in the order
  • USA light tanks missing their icon in the tank designer
  • your production can now convert fighter into jet fighter
  • Jet fighters also receive bonuses from aircraft design company

DOWNLOAD


Version 14.12.21 for Hearts of Iron 4 (v1.11.4)

DOWNLOAD

How to install mod?

To install the mod for the game Hearts of Iron 4, unpack the contents of the archive to the folder Documents\Paradox Interactive\Hearts of Iron IV\mod and enable the modification in the launcher.

File info

Download links will be available in sec.

You can log in to your account or register on the site to download mods without waiting.

+1
03:13
1769
RSS
Tom
06:38

Only available on 1.11.4? is this compatible with older version? (1.10.8 for example). if not, can you make it compatible, please?

Abhijeet
07:27

Please update the disaster mod

DC
10:55

It crashes with 1.11

Loading...